Installation

These instructions cover installing BunnyMusicFile on UNIX-like operation systems.

Perl

You’ll need version 5.12 or greater which should be present on any remotely current system. You’ll also need to install the following modules:

  • Audio::FLAC::Header
  • Clone
  • Data::Dumper
  • Encode
  • Encode::Guess
  • Expoter::Lite
  • File::Copy
  • File::HomeDir
  • IO::String
  • Misc::DmUtil
  • MP3::Tag
  • Text::ParseWords

BunnyMusicFile

Download the latest version, and uncompress to a temporary directory. Then:

perl Makefile.PL
sudo make install

You can test the installation with perl -e "use Audio::BunnyMusicFile", no error messages means success.

MP3 support

Install LAME.

FLAC support

Install FLAC.

MP4 support

For decoding support install ffmpeg. For encoding install faac. You should also install libmp4v2 which provides the mp4tags utility.